Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - TOTVS Backoffice Linha Protheus - ADVPL - Campos da aba frete/despesas no pedido de compra

Ocorrência
Ao utilizar os pontos de entrada da rotina de geração de Pedidos de Compra (MATA121), não consigo encontrar os campos da aba Frete/Despesas na variável aCols.

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) – ADVPL – A partir da versão 12.1.17

Causa
Os campos da aba Frete/Despesas são armazenados em vetores e variáveis para a montagem dos campos da MsGet(), contudo por não pertencerem a grid de dados, os mesmos não constam na variável aCols.

Solução
Utilizar as variáveis abaixo:

Campo
Descrição
Variável
C7_TPFRETE
Tp. Frete
cTpFrete
C7_DESPESA
Despesas
aValores[4]
C7_FRETE
Valor do Frete
aValores[3]
C7_SEGURO
Seguro
aValores[7]
C7_TOTAL
Total (Frete + Despesas)
aValores[8]
C7_TRANSP
Transportadora
cTransp
C7_TRANSLJ
Loja
cTransLj
C7_FRETCON
Vl. Frete Contratado
nFreteCon


Observação
Por serem variáveis de escopo privado as mesmas podem ser alteradas sem aviso prévio, assim sendo, será necessária a realização do processo de depuração (debug) para validar se as mesmas se mantém nas mesmas variáveis.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _