Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - TEC - Index name is inactive and cannot be referenced

relogio.png Tempo aproximado para leitura:  00:01:15 min

Ocorrência
Ao executar um programa Progress é apresentado o erro Index index-name is inactive and cannot be referenced (995).

Ambiente
Framework - Framework (Linha Datasul) - Progress OpenEdge – Todas as versões

Causa
Indica que o índice está inativo no banco de dados. Para ativá-lo é necessário executar o comando idxbuild.

Solução
Para ativar os índices inativos de um banco de dados Progress Openedge, realize os seguintes passos:

1. Acesse o aplicativo proenv do Progress e vá até o diretório onde estão os arquivos do banco;
2. Digite o comando: proutil nomedobanco -C idxbuild inactiveindexes;
3. Ao término do processo inicie o banco novamente.

É possível também reindexar todas as tabela do banco de dados, executando o comando:
proutil banco -C idxbuild all.

Importante
O comando idxbuild é realizado com o banco offline.
Tenha um backup válido do banco, pois se o processo de idxbuild não finalizar corretamente, deixará o banco em um estado inconsistente, exigindo o retorno do backup.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _