Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - TOTVS Backoffice (Linha Protheus) - ADVPL - Peer certificate cannot be authenticated with given CA certificates


Ocorrência

Ao consumir um serviço ocorre o seguinte erro:

Mensagem de erro: Erro SendSoapMsg: A WSDL exception occurred at0:0 
WsdlParser Exception : Error sending SOAP message: Peer certificate cannot be authenticated with given CA certificates.

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) – ADVPL– Todas versões

Causa
Existem Web Services exigem conexão segura para se acessar (SSL), exigindo certificados de uma autoridade certificadora (CA). Normalmente o PFX contém no certificado de CA apenas a cadeia de certificados mais necessária, pois conta com o comportamento do Windows, que procurará no repositório os certificados que faltarem. Nesse caso, após feito a extração dos arquivos de certificado e chave do PFX, a conexão feita pela TWsdlManager não é realizada, devido a falta de certificados na cadeia de certificados de CA

Solução

Segue link com passo a passo desta ocorrência
Acesso a Web Services que exigem certificados de CA

Para web services que não exige certificado é necessário utilizar a propriedade lSSLInsecure

 

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 1

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _