Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - TEC - Error formatting message no log do JBoss

time.png Tempo aproximado para leitura: 00:02:10 min

Ocorrência
No log do JBoss é apresentada a mensagem Error formatting message

Ambiente
Framework - Framework (Linha Datasul) – Jboss – Versão 12

Causa 
A variável -Xss do arquivo run.bat está inferior ao valor 256k.

Solução
Verifique no arquivo ..\ServidorAplicacao\jboss-4.2.3.GA\bin\run.bat os parâmetros abaixo, deixe o -Xmx e o -Xms iguais. No exemplo, está com 1g, dependendo do seu ambiente e a demanda. O -Xss de 256, podendo ser 512k.

set JAVA_OPTS=%JAVA_OPTS% -Xms1g -Xmx1g -Xss256k -XX:MaxPermSize=512m -XX:+UseParallelGC -XX:ParallelGCThreads=10


Recomendamos que os parâmetros "-Xms" - memória inicial alocada para o Jboss e "-Xmx" - memória máxima alocada para o Jboss estejam configurados como mesmo valor, para evitar que o Garbage Collector seja executado mais vezes que o necessário. O Garbage Collector é utilizado pelo Java para limpar os objetos inativos em memória, sendo que cada vez que este é executado, o processo Java congela completamente e só é liberado após o Garbage Collector ser finalizado.

Abaixo uma breve descrição de cada um desses parâmetros:
-Xms: Parâmetro de memória que define o mínimo de memória para a aplicação;
-Xmx: Parâmetro de memória que define o máximo de memória para a aplicação;
-Xss: Tamanho da pilha reservada para cada thread;
-XX:MaxPermSize: Tamanho máximo da área de objetos permanentes em memória;
-XX:+UseParallelGC: Habilita o Garbage Collector para abrir várias thread e atuar paralelamente;
-XX:ParallelGCThreads: Número de thread que serão abertas para Garbage Collector. Por default é aberto uma Thread para cada processador.

Por fim, s
alve o arquivo e reinicie o Serviço do JBoss.

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _