Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - Linha Protheus - TAF - Configuração - Erro ao abrir o SM0 exclusivo


Ocorrência
Ao executar a atualização do TAF através da UPDDISTR ou ao cadastrar uma nova empresa no TAF, deparar-se com o problema que resulta em um erro ao abrir SM0 exclusivo.

Ambiente

Cross Segmento - TOTVS Backoffice (Linha Protheus) - TOTVS Automação Fiscal - À partir da release 12.1.33

Causa
Este incidente ocorre quando algum serviço da aplicação está consumindo o cadastro de empresas (SM0):



Solução

  1. Parar o Serviço TAF-WS no TAF Segregado: No ambiente de TAF segregado, é comum deparar-se com essa situação devido à ativação do serviço TAF-WS. Para solucionar esse problema, é necessário interromper o serviço. Siga as instruções abaixo para encerrar a aplicação:

    RH - Linha Protheus - TAF - SERVIÇOS - Como parar o serviço TAF-WS

  2. Identificar e Reiniciar o Serviço Responsável pelo Consumo do Cadastro de Empresas: Em outra situação, será imprescindível reiniciar ou parar o serviço que está consumindo o cadastro de empresas. Isso ajudará a liberar o SM0 e solucionar o erro.

  3. Gerenciar Schedules no appserver.ini do Protheus: Verifique a existência de Schedules configurados no arquivo appserver.ini do Protheus. Se houver Schedules configurados, siga as etapas abaixo:

    • Comente as chaves de configuração no arquivo appserver.ini.
    • Após executar o UPDDISTR, descomente as chaves de configuração para reativar o Schedule.

Dica Adicional: Identificar o Serviço Consumindo o Cadastro de Empresas: Para determinar qual serviço está consumindo o cadastro de empresas, siga o procedimento abaixo:

  • Acesse o diretório $\system, onde "$" representa o diretório de instalação do sistema.
  • Tente renomear o arquivo "sigamat.emp".
  • O sistema operacional impedirá a ação e exibirá uma mensagem indicando o serviço que está bloqueando a renomeação do arquivo.

Com essas soluções e dicas, você poderá resolver o erro ao abrir SM0 exclusivo ao atualizar o TAF ou cadastrar empresas no TAF. Certifique-se de seguir as instruções com precisão para alcançar uma resolução bem-sucedida.

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 1

2 Comentários

  • Avatar
    Santos Leonardo

    Bom!

    0
    Ações de comentário Permalink
  • Avatar
    PATRICIA SIXTO VILELA

    Verifique também o arquivo APPSERVER.INI do TAF dentro de BIN/APPSERVER se existe alguma seção [ONSTART], se existir, comente com o ;
    Exemplo:
    ;[ONSTART]

    0
    Ações de comentário Permalink
Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _