Ocorrência
Ao atualizar o TAF executando UPDDISTR ou cadastrando empresa no TAF, ocorre o problema (Erro ao abrir SM0 exclusivo)
Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - TOTVS Automação Fiscal - À partir da release 12.1.27
Causa
Esse incidente ocorre, quanto existe algum serviço da aplicação consumindo o cadastro de empresas (SM0):
Solução
1 - No TAF Segregado é comum ocorrer este caso devido ao serviço TAF-WS estar ativo e o mesmo deverá estar parado. Para encerrar a aplicação siga o material conforme abaixo:
TAF - SERVIÇOS - Como parar o serviço TAF-WS
2 - Outro cenário, será necessário reiniciar (ou parar) o serviço que está consumindo o cadastro de empresas.
Dica: Para saber qual o serviço que está consumindo este cadastro, acesse o diretório $\system\ - onde $ se trata do diretório de instalação do sistema - e tente renomear o arquivo sigamat.emp. O sistema operacional impedirá esta ação e informará qual o serviço que impede que o arquivo seja renomeado.
2 Comentários