Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

TOTVS Jurídico - Departamentos - Departamento(SIGAJURI) - Correção de Erro na Tabela NVH ao rodar o UPDDISTR

time.png Tempo aproximado para leitura: 00:05:00 min

 

Ocorrência

Ao rodar o UPDDISTR ocorre erro na tabela "Config Campos de Pesquisa NVH".

Ambiente

TOTVS Jurídico - Departamentos - Departamento(SIGAJURI) - A partir da versão 12;


Causa

Esse erro na tabela NVH, ocorre na aplicação do UPDDISTR ou MP710TO120, devido a inconsistência das informações da SIX, SX2 e SX3 gravadas no ambiente do cliente e que porventura, estejam diferentes das contidas no Dicionário de Dados Completo ou Diferencial do Protheus.;


Solução

Para o procedimento deste incidente, requer o apoio do TI ou um analista especialista com conhecimento técnico em estrutura Protheus e banco de dados.

 

  • Validação da SIX(Índices);
    • 1 - Acessar APSDU - Ir em Arquivo - Abrir ou (CTRL + B para abrir);
    • 1.2 - Acessar a System e abrir o arquivo SIX(Índices);
    • 2 - Verificar se os índices (SIX) da tabela NVH estão conforme o padrão, caso não estejam realizar o ajuste;
    • Estrutura da NVH(Índice)

six_nvh.gif

  • Validação da SX2(Tabela);
    • 3 - Ir em Arquivo - Abrir ou (CTRL + B para abrir);
    • 3.1 - Acessar a System e abrir o arquivo SX2(Tabela);
    • 4 - Verificar se a tabela (SX2) da NVH está conforme o padrão, caso não estejam realizar o ajuste;
    • Estrutura da NVH(Tabela)

NVH_SX2.gif

  • Validação da SX3(Campos);
    • 5 - Ir em Arquivo - Abrir ou (CTRL + B para abrir);
    • 5.1 - Acessar a System e abrir o arquivo SX3(Campos);
    • 6 - Verificar se os campos (SX3) da NVH está conforme o padrão, caso não estejam realizar o ajuste;
    • Estrutura da NVH(Campos)

SX3_NVH.gif

Observação: Verifique a ordem dos campos e o tipo, pois se não estiverem corretos pode continuar o incidente; 

 

  • Topconnect
    • 7 - Após realizar o ajuste das informações "SIX,SX2 e SX3", abrir novamente o Driver e selecionar a opção TopConnect;
    • 8 - Selecionar e Dropar a tabela NVH para que seja criada novamente com os ajustes realizados nos dicionários "SIX,SX2 e SX3";

drope.gif

    • 9 - Acessar a estrutura do seu Protheus e na pasta Appserver deletar o arquivo "mpupddistri.tsk".Obs. Não há necessidade de deletar os arquivos da pasta SystemLoad;
    • 10 -Aplicar novamente o UPDDISTR.

Observação:

Sempre realizar o processo primeiro em ambiente de homologação e realizar o backup do ambiente antes de realizar os procedimentos;

 

Saiba Mais:

A documentação completa, encontra-se no TDN de como realizar o procedimento: JUR0066_Correção_do_erro_na_tabela_NVH

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _