Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - TOTVS Backoffice Linha Protheus - ADVPL - Update error - lock required - File (...)

time.pngTempo aproximado para leitura: 00:04:00 min

Ocorrência
ERRO THREAD (xxx, xxxxx) 28/05/2007 09:52:27 Stack :Update error - lock required - File: SX5990 in file

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) – ADVPL – A partir da versão 11.8

Causa
Quando uma aplicação AdvPL tenta realizar uma atribuição, REPLACE ou FieldPut() em qualquer campo de um determinado Alias, e o registro atualmente posicionado não estiver devidamente bloqueado pelo usuário atual para alteração (DBRLock(), MSRLock() e/ou RecLock()), a aplicação é finalizada com a mensagem de erro acima, onde é informado o arquivo a ser atualizado, e a linha do código-fonte onde houve a tentativa de atualização, seguinda da pilha de chamadas.

Solução
Para solucionar essa ocorrência, deve ser verificado o código-fonte que realiza a alteração do registro, para certificar-se que o registro posicionado para alteração realmente foi bloqueado para alteração. Na grande maioria dos casos, não foi verificado no código-fonte se houve sucesso na tentativa de bloqueio do registro para alteração.

Informações acionais
São boas práticas de programação, sempre ao fazer uma alteração de registro em uma tabela, utilizar ALIAS->CAMPO para fazer a atribuição, ou ainda a função FieldPut(). Não é boa prática fazer a atualização de um campo SEM utilizar o ALIAS.

Exemplo:

Ao invés de : 
CAMPO := xConteudo

Utilize :
ALIAS->CAMPO := xConteudo

Saiba mais
Update error - lock required - File (...)

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 1

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _