Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Totvs Backoffice Protheus - SIGAGCT - Ao tentar realizar medição não aparece o contrato ou planilha



Ocorrência
Ao tentar realizar medição não aparece o contrato ou planilha

Ambiente
Microsiga Protheus – Gestão de Contratos – A partir da versão 12


Causa
Esse incidente pode ocorrer quando em migração de versão ou inconsistência de base de dados alguns campos da planilha e cronograma financeiro do contrato estão gravados com informação incorreta ou em branco.

Solução
Abaixo seguem os pontos que se tem mapeados para esta ocorrência:

 

1. Verificar se os campos abaixo estão devidamente preenchidos:

Planilha:
CNA_CRONOG -> deve estar preenchido com o número do cronograma referente a esta planilha;
CNA_CONTRA -> deve estar preenchido com o número do contrato referente a esta planilha.
Cronograma financeiro:
CNF_NUMPLA -> deve estar preenchido com o número da planilha correspondente a este cronograma;
CNF_CONTRA -> deve estar preenchido número do contrato referente a esta cronograma.

 

2. Também quando o contrato/planilha do contrato está fora da vigência, a rotina por padrão não trará o mesmo para medir, por isso, deve-se verificar se a Database que está sendo acessado o sistema para realizar a medição está contemplada entre as datas de Inicio e Fim do Contrato/Planilha dos campos CN9_DTINIC (Data Inicial do Contrato) / CN9_DTFIM (Data Final do Contrato) e CNA_DTINI (Data Inicial da Planilha) / CNA_DTFIM (Data Final da planilha).
Além destes campos, o contrato deve estar com a legenda "verde - Vigente"/Campo CN9_SITUAC = 05.

 

3. Falta de saldo para o contrato/planilha/competência, necessitando assim a revisão do contrato para se inserir mais saldo caso desejado.

Em relação a checagem de saldo do contrato/planilha/competência da opção 2, um teste que pode ser realizado em ambiente de homologação, é a realização do Processamento do Recalculo dos Saldos do Contrato, mencionada artigo do link abaixo, verificando se ocorre alguma alteração de valores de saldos, alteração essa que possa corrigir o problema em questão da medição do contrato em específico ou verificando a falta do saldo após o recálculo.

Cross Segmentos - Totvs Backoffice Protheus - SIGAGCT - Como realizar o Reajuste de Saldo em contratos, planilhas e cronograma financeiro ?

 

4. Referente a compartilhamento de tabelas no Gestão de Contratos, todas as tabelas envolvidas do módulo possuem seu compartilhamento "Exclusivo".

No caso de compartilhamento de alguma tabela do módulo, é recomendado que todo o conjunto de tabelas do módulo possuam o mesmo compartilhamento entre si, conforme orientações do artigo abaixo:

Cross Segmentos - Totvs Backoffice Protheus - SIGAGCT - Compartilhamento de Tabelas no Gestão de Contratos 

 

5. Checar se existe para o contrato em questão, registro ativo (não deletado) na tabela CPD com as informações corretas de Filial, Contrato e Planilha de acordo com o contrato e compartilhamento das tabelas, da mesma forma que o de um contrato em que este problema não acontece.

 

6. Caso possua controle de acesso no contrato habilitado, com o campo CN9_VLDCTR = Sim, deve-se verificar se o usuário que está realizando a medição possui acesso concedido a realizar medição do contrato, e se o contrato possui acesso autorizado a realizar medições na Filial que está se tentando fazer a medição, conforme informações contidas no artigo abaixo:

Cross Segmentos - Totvs Backoffice Protheus - SIGAGCT - Controle de Acesso ao contrato no Gestão de Contratos

 

7.Verifique se não possui Medição Rejeitada para essa Planilha.Caso possua e tenha necessidade de medir será necessário excluir a Medição rejeitada , para incluir uma nova Medição.

 

Saiba Mais:
Ao tentar realizar medição não aparece o contrato/planilha

GCT0102 - Aviso de Help CNNOTRANS ao realizar a Medição

Cross Segmentos - Totvs Backoffice Protheus - SIGAGCT - Controle de Acesso ao contrato no Gestão de Contratos

Artigos Materiais - Gestão de Contratos - (SIGAGCT)

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _