Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - TOTVS Backoffice Linha Protheus - ADVPL - Cancelamento da função Processa() não está funcionando

time.pngTempo aproximado para leitura: 00:02:00 min

Ocorrência

O cancelamento do processamento de rotinas executadas através da função Processa() não está funcionando.

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) – ADVPL – A partir da versão 12.1.17

Causa
Esse incidente ocorre, pois o tratamento de cancelar a execução deve ser realizado pelo usuário:

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

Na chamada da processa deve ser declarada a variável Private lAbortPrint:

User Function TestPrc(aCampos, oLbx)
Private lAbortPrint:=.F.
Processa( {|| U_TestSX3(aCampos) }, "Aguarde...", "Carregando definição dos campos...",.T.)

E no laço de processamento deve-se utilizar a variável para abortar o processo:

WHILE !Eof() .AND. !lAbortPrint
IncProc()
sleep(300)
PROCESSMESSAGES()
Aadd(aCampos, {X3_ARQUIVO, X3_ORDEM, X3_CAMPO})
DbSkip()
END

Saiba mais
Processa - Diálogo na execução de processo monitorado

 

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 1

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _