Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - Linha Protheus - TAF - eSocial - Periódicos - Ao integrar o evento S-1200 para RPA, ocorre o erro tag <codrubr> não existe na base de dados

Ocorrência
Ao integrar o evento S-1200 para RPA, ocorre o erro tag <codrubr> não existe na base de dados.

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - TOTVS Automação Fiscal - Todas as versões

Causa
Este erro ocorre porque na verdade não há o código informado na tag <ideTabrubr> dentro da tabela T3M e, ou, C8R.

Os ID's de identificação se enquadram no conjunto à seguir: INSS, ISS, SEST/SENAT (Título possui retenção de impostos); Basicamente, a tag <ideTabrubr> vem assim: <ideTabrubr>SEST</ideTabrubr>

Capturar.JPG

Na imagem acima, pode-se ver que o identificador não corresponde aos identificadores padrão gerados pelo produto HCM, com descrição 'TBPADRAO' ou códigos numéricos.

Se você tentar uma integração de algum XML para S-1200 RPA, e ocorrer este erro, abra a rotina de Tabela de Rubricas do TAF, veja os identificadores, como no exemplo à seguir;

tabela.JPG

Os identificadores acima na coluna destacada, correspondente a tag <ideTabrubr> que é diferente da tag <codRubr>.

Você também pode abrir o XML do S-1200 e verificar que todos os XML's do S-1200 foram lançados com a mesma identificação na tag <ideTabrubr>, e confirmar isso ao analisar que a tabela C8R e o e-Social Web contém apenas o <ideTabrubr>000001<\ideTabrubr> (exemplo).

Solução
Para solucionar, você precisa cadastrar novas tabelas de rubricas diretamente no TAF, e transmitir ao Governo, com seus determinados códigos de rubricas. Lembre-se; código de rubrica e id da rubrica são coisas diferentes.

Ao cadastrar a tabela de rubrica com o identificador correto, será possível realizar a integração.

As tabelas de rubricas são geradas na carga de tabelas pelo HCM, e são integrados e transmitidos corretamente. Porém, ao gerar um XML S-1200 de RPA, ele vem do Financeiro, módulo CD2014, e não é possível gerar novas tabelas de Rubrica pelo HCM, ou pelo Financeiro.

O link à seguir orienta como gerar o XML S-1200 RPA pelo Financeirohttp://tdn.totvs.com/pages/viewpage.action?pageId=309397300

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _