Ocorrência
Help FA050BAIXA na Exclusão do Documento de Entrada
Ambiente
Microsiga Protheus – Compras – A partir da versão 11.80
Causa
Para que a mensagem FA050BAIXA não seja mostrada quando se utiliza o financeiro compartilhado, terá que ter as tabelas abaixo compartilhadas.
Possíveis soluções :
1- )Tabelas a ser compartilhada para que considere o Pedido X Adiantamento
(FIE - Relacionamento Pedidos X Adiantamento)
(FR3 - Relacionamento Pedidos X Compensação)
Tabelas envolvidas no processo:
FIE, FR3, FK1, FK2, FK3, FK4, FK5, FK6, FK7, FK8, FK9, FKA, SE1, SE2, SE5
2- ) Tabelas a serem observados o conteúdo:
No(s) título(s) a pagar gerado(s) a partir da nota de entrada que precisa ser excluída, verifique como estão os conteúdos dos campos : E2_BAIXA e E2_SALDO pode haver alguma informação de baixa nos títulos a pagar.
Verificar se a baixa foi cancelada, se existe registro deste cancelamento na tabela FK2, pois o help é exibido quando o sistema somente localiza o movimento de baixa dentro da FK2 e não localiza o movimento do estorno/cancelamento/exclusão da baixa.
IMPORTANTE :
Se em seu ambiente o sistema estiver pemitindo a exclusão de um documento de entrada, mesmo com títulos baixados no financeiro, verifique se o processo de baixa gerou movimento na tabela FK2 ( movimentação gerada por padrão do sistema ), pois para permitir ou não a exclusão da NFE ( executado pelo fonte FINXAPI ) o sistema verifica os conteúdos dos campos FK2_VALOR com o E2_VALOR, se forem diferentes, é porque houve alguma inconsistência no momento da realização da baixa e por isso, a exclusão ocorreu. Os campos de IDDOC também são verificados para a localização dos movimentos dentro das tabelas FK´s.
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