FAQs - Suporte técnico

MP - GPE - Erro: Data width error - Field: R2_TDIASAF

Ocorrência
Data width error - Field: R2_TDIASAF  na geração da RAIS

Ambiente
Microsiga Protheus – Gestão de Pessoal – A partir da versão 12

Causa
O erro é gerado quando o funcionário possui um afastamento cujo os dias pagos pela empresa é maior que 15 dias.

Solução
Verifique se existe em Lançamentos/ Ausência (SR8) alguma matrícula com afastamento cujo campo Dias Pagos Empresa (R8_DPAGOS) está maior que 15 dias.
Caso tenha registros com conteúdo deste campo maior que 15 dias, o conteúdo deve ser ajustado para 15 dias.
Depois, execute novamente a Geração dos dados para a RAIS (GPEM500) e em seguida a Geração do Magnético da RAIS (GPEM530).
No programa da RAIS, o arquivo importado deve ser excluído e importado novamente para não gerar duplicidade de informações.

Se os campos acima mencionados estiverem com conteúdo correto, execute o backup do RPO e a aplicação do pacote abaixo, opte pelo pacote de acordo com a versão de seu sistema:

https://suporte.totvs.com/portal/p/10098/download#000006/all/all/search/rh_expedicao

Importante:
O campo Dias Pagos Empresa (R8_DPAGOS) é alimentado a partir da informação do campo Dias Pg Empre - que fica dentro da definições de cálculo/ tipos de ausência.
Na analise dos afastamentos maior que 15 dias é de extrema importância observar o tipo de afastamento, pois alguns deles tem mais que 15 dias pagos pela empresa e está correto. Exemplo: Férias e Licença maternidade. 
Esse erro costuma acontecer quando o funcionário tem especificamente afastamentos do tipo 003 - Afastamento temporário acidente de trabalho e/ ou 004 - Afastamento temporário por doença com dias pagos pela empresa maior que 15 dias. 

Esse artigo foi útil?
Usuários que acharam isso útil: 3 de 4

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _