FAQs - Suporte técnico

RM - Frame - Menus desabilitados em aplicativos Delphi


Ocorrência

Ao acessar os aplicativos Delphi, alguns menus tais como Selecionar Coligada, Customização, Gerador de Relatórios estão desabilitados, conforme exemplo no print abaixo:



Ambiente
RM– Framework – Todas as versões do RM. 

Causa
Esse incidente ocorre por falta de parametrização no BDE, considerando que o usuário está associado a um perfil com permissão aos mesmos. 

Solução
Para solucionar esta inconsistência siga os passos abaixo:

  1. Feche o Sistema (RM.exe e módulos Delphi)
  2. Acesse o BDE Administrator;
  3. Apague todas as conexões criadas;
  4. Crie uma nova conexão;
    Importante
    Caso seu SQL Server esteja na versão 2012 ou superior, siga os passos do link abaixo:
    http://tdn.totvs.com/display/public/rm/RM+Conversor+-+ODBC+SQL+Server+2012
  5. Ainda no BDE na aba Database, selecione o alias desejado (Ex.: CorporeRM);
  6. Altere o valor da propriedade BLOB SIZE para 512;
  7. Na propriedade BLOBS TO CACHE coloque o valor 1024;
  8. Acesse a aba Configuration;
  9. Expanda o item Configuration;
  10. Expanda o item Drivers;
  11. Expanda o item ODBC;
  12. Selecione SQL Server Native Client 11.0;
  13. Altere o valor da propriedade BLOB SIZE para 512;
  14. Na propriedade BLOBS TO CACHE coloque o valor 1024;
  15. Salve as alterações;
  16. Feche o BDE;
  17. Acesse novamente o Sistema;
Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _