Ocorrência
Ocorrência do Help FWFORMCANCEL na exclusão do Fornecedor
Ambiente
Microsiga Protheus – Estoque - A partir da versão 12.1.17
Causas :
1- ) No módulo COMPRAS, ao tentar realizar a exclusão de um Fornecedor (MATA020) é apresentada a (ocorrência ou mensagem) citada abaixo:
Problema: Violação de Integridade. Foi encontrada referência de Código ( A2_CODIGO ) na tabela SAD - Amarração Grupo x Fornecedor. Fórmula SA2MASTER. Linha : 1
Esse incidente ocorre quando há um problema na Integridade Relacional (SX9) para as tabelas do módulo de Compras ( SA2 e SAD ).
Será necessário executar um ajuste pelo dicionário de Dados, ao tentar excluir um registro de fornecedor na rotina de Fornecedores (MATA020), a rotina fará o processo de exclusão corretamente.
Solução :
Para solucionar essa ocorrência, realize os seguintes passos:
Procedimento para ajustar a tabela SX9:
Acessar o programa APSDU.
Acesse a tabela SX9 e faça um filtro igual ao print abaixo :
Verifique se na linha 1, o relacionamento está com o campo X9_ENABLE = N, caso esteja S, altere para N.
Essa situação está corrigida no dicionário padrão a partir do release 2210 do Protheus.
OBS: Tal procedimento é de correção exclusiva para os administradores
2- ) No módulo COMPRAS/ESTOQUE, ao tentar realizar a exclusão de um Fornecedor (MATA020) é apresentada a (ocorrência ou mensagem) citada abaixo:
Problema: Violação de Integridade. Foi encontrada referência de Banco (FIL_BANCO) + Agência (FIL_AGENCI) + DV AGÊNCIA (FIL_DVAGE) + CONTA (FIL_CONTA) + DVCONTA (FIL_DVCTA) na tabela SE2 - Contas a Pagar
Esse incidente ocorre quando há um problema na Integridade Relacional (SX9) para as tabelas do módulo de Compras / Estoque.
Através desse ajuste pelo dicionário de Dados, ao tentar excluir um registro de fornecedor na rotina de Fornecedores (MATA020), a rotina fará o processo de exclusão corretamente.
Solução
Para solucionar essa ocorrência, realize os seguintes passos:
Procedimento para ajustar a tabela SX9:
1º - Acessar o programa APSDU:
2º Acessar com o usuário administrador:
3º Clicar em “Arquivo” -> “Abrir” e selecionar o menu Driver “Ctree (CTREECDX) “:
4º Dentro do diretório do servidor acessar a pasta “system” e selecionar a tabela SX9:
5º Será apresentada uma tela semelhante a esta:
6º Acessar a opção “Utilitário” -> “Filtrar”, alterar o parâmetro “Campos” para X9_CDOM, no parâmetro “Expressão” preencher com “SE2” e incluir, depois clique no botão "AND" e X9_DOM parâmetro “Expressão” preencher com “FIL” e incluir e por fim clicar no botão Ok :
7º Os dados serão filtrados e a tela deverá ficar desta forma:
8º Eliminar o registro pelo teclado (DEL) da linha com X9_IDENT = '001'
Pronto, abrir o Protheus novamente e na rotina de Fornecedores, excluir o registro novamente.
DICA: Caso o procedimento acima não resolva:
- Deletar o X9_IDENT igual 002, caso o X9_EXPDOM for igual a FIL_BANCO+FIL_AGENCI+FIL_DVAGE+FIL_CONTA+FIL_DVCTA.
OBS: Tal procedimento é de correção exclusiva para os administradores
Saiba Mais :
Artigos Materiais - Compras (SIGACOM)
1 Comentários