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RM - SAU - Erro 500 ao acessar Painel de Chamadas ou teste de autenticação do TBC

Ocorrência
Ao abrir o Painel de Chamadas ou executar o método de teste de autenticação do TBC ocorre um

"Erro 500'. 

Ambiente
RM Saúde Versão 12.1.18 e superiores

Causa
Múltiplas causas. Neste caso:
- A entrada do Painel no IIS está usando um pool de aplicativos configurado em uma versão do .NET Framework desatualizada.
- Falta de arquivos necessários na pasta de instalação do TOTVS Business Connect (TBC).
- Definição de porta de comunicação inconsistente entre arquivos de configuração do Painel e do serviço de Host do RM.
 

Solução
1. Acesse a subpasta RM.Net dentro da pasta de instalação do RMSaude.
2. Localize os arquivos Castle.Core.dll Castle.Windsor.dll.
3. Copie estes arquivos e cole-os na subpasta bin dentro da pasta de instalação do TOTVS Business Connect. Certifique-se de que além destes arquivos também existem nesse local os outros mencionados na documentação de instalação do Painel.
4. Acesse o arquivo web.config dentro da pasta de instalação do TBC e configure a porta padrão de conexão para comunicação entre TBC e RM. A mesma porta deve ser usada também no arquivo RM.Host.Service.config que existe na subpasta RM.Net dentro da pasta de instalação do RM.
Em ambos os arquivo Dentro da tag <appSettings> insira a tag <add key="Port" value="8050" />   ou apague a tag que contenha qualquer outra porta em ambos os arquivos. Assim o sistema assumirá a porta padrão.
5. Configurar o Painel para usar um Pool de Aplicativos que use o .NET Framework 4.0 ou superior.

 

Saiba Mais
Para maiores informações sobre configurações do Painel de Chamadas e TBC consulte as documentações abaixo
Instalar WS do TBC
Painel de Chamadas

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