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Ocorrência
Após alterar o perfil vinculado a um usuário, consistindo informações de Acesso a Campos, mesmo realizando logout e login as alterações de permissão não são aplicadas:
Ambiente
Framework - Linha RM - Frame - Todas as versões do sistema RM
Causa
Essa situação ocorre porque as definições de acessibilidade a campos são mantidas em cache de memória do serviço RM.HOST.SERVICE.
Solução
Para solucionar essa ocorrência, após realizadas alterações no Acesso a Campos, será necessário reiniciar o serviço de host.
Em ambiente 3 ou N camadas, o processo deve ser realizado nos servidores de Aplicação.
Para reiniciar o serviço RM.Host.Service, siga os passos abaixo:
- Acesse o caminho UNIDADE:\totvs\CorporeRM\RM.Net;
- Clique com o botão direito do mouse em RM.Host.ServiceManager.exe;
- Selecione a opção Executar como Administrador;
- Clique em Parar;
- Quando o status estiver como Parado, clique em Iniciar:
- Aguarde até que o status esteja como Iniciado.
Importante
Quando realizar o processo acima em servidor de Aplicação, todos os usuários irão deslogar automaticamente, pois o serviço será reiniciado, salvo quando o ambiente está configurado para utilizar balanceamento nativo, quando se poderá reiniciar um serviço de cada vez.
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