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TEC - DBACCESS - Queda da aplicação quando configurado a chave logFull

TEC - DBACCESS - Queda da aplicação quando configurado a chave logFull

Ocorrência

Queda da aplicação em ambientes configurados com a chave logFull

 

Ambiente

TOTVS | DBAccess

 

Causa

Quando configurado o uso da logFull, a rotina de tratamento de exceções realiza a coleta e o registro de informações adicionais das tabelas correlatas.

A coleta excessiva de informações realizada durante o erro de update por falha de localização de registros, causava a queda da aplicação.

 

Importante

A chave logFull somente deve ser utilizada para diagnóstico e quando explicitamente solicitado pela equipe de desenvolvimento.

 

Solução

Realize a atualização do DBAccess.

Alternativamente, desabilite a chave logFull através do DBMonitor ou através da edição do arquivo de configuração do DBAccess.

  • Através do DBMonitor
    1. Conecte-se ao DBAccess com as credenciais de administração;
    2. Acesse a guia Configurações e em seguida Avançado;
    3. Desabilite a opção "Detalhamento de mensagens/ocorrências";
    4. Reinicialize a instância do DBAccess.
  • Através da edição do arquivo de configuração do DBAccess
    1. Interromper a instância do DBAccess;
    2. Abra o arquivo de configuração do DBAccess para edição;
    3. Reconfigure o valor da chave logFull para 0;
    4. Reinicialize a instância do DBAccess.

 

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