Ocorrência
Queda da aplicação em ambientes configurados com a chave logFull
Ambiente
TOTVS | DBAccess
Causa
Quando configurado o uso da logFull, a rotina de tratamento de exceções realiza a coleta e o registro de informações adicionais das tabelas correlatas.
A coleta excessiva de informações realizada durante o erro de update por falha de localização de registros, causava a queda da aplicação.
Importante
A chave logFull somente deve ser utilizada para diagnóstico e quando explicitamente solicitado pela equipe de desenvolvimento.
Solução
Realize a atualização do DBAccess.
Alternativamente, desabilite a chave logFull através do DBMonitor ou através da edição do arquivo de configuração do DBAccess.
- Através do DBMonitor
- Conecte-se ao DBAccess com as credenciais de administração;
- Acesse a guia Configurações e em seguida Avançado;
- Desabilite a opção "Detalhamento de mensagens/ocorrências";
- Reinicialize a instância do DBAccess.
- Através da edição do arquivo de configuração do DBAccess
- Interromper a instância do DBAccess;
- Abra o arquivo de configuração do DBAccess para edição;
- Reconfigure o valor da chave logFull para 0;
- Reinicialize a instância do DBAccess.
Mais informações
- DBAccess, arquivo de configuração: chave logFull
- DBAccess, correção: Queda da aplicação quando configurado a chave logFull
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