Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - TOTVS Backoffice Linha Protheus - ADVPL - Erro: Setvalue não preenche campo memo em mvc

Ocorrência
Ao utilizar o método SetValue() em uma rotina em MVC para preencher um campo do tipo Memo, o mesmo não é preenchido.

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) – ADVPL – Todas versões

Causa 
Dependendo do momento em que se estiver tentando realizar a inserção de dados em um submodelo de uma rotina MVC, está ação pode não ser replicada para view.

Solução
Após atribuir o valor ao campo desejado utilize o método Refresh() da classe FwFormView() passando o identificador da subview que se deseja atualizar.

Fonte

oModel:SetValue("ZA0_NOTAS", AllTrim(oModel:GetValue("ZA0_NOME"))) // ALTERA CAMPO MEMO
oView:Refresh("VW_MASTERZA0") // ATUALIZAÇÃO A SUBVIEW ONDE O CAMPO ESTÁ CONTIDO


Saiba mais
FWFormView

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _