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RM - ENGENHARIA - Atualização via DEPLOY GRANULAR não lista todos tickets

Ocorrência
Ao executar o instalador de um patch e selecionar Instalação Granular, ao carregar a tela de seleção dos tickets/issues para aplicação da versão, não são listados corretamente os itens para seleção.

mceclip1.png

Ambiente
RM – Engenharia – Versão 12.1.x

Causa
O instalador faz a leitura de algumas informações para que sejam aplicados filtros dos itens a serem exibidos na tela, evitando assim a instalação de informações já aplicadas. Um dos itens que o instalador faz a leitura é o registro do Windows [UltimoPatchFullInstalado].

mceclip0.png

No caso em questão o registro constava desatualizado, e assim o sistema compara a versão que está instalando com a versão antiga instalada.

Ao realizar a validação em questão, como as informações são divergentes, o sistema não retornar corretamente os itens a serem listados na tela do deploy granular.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Acesse o Gerenciador de Registros do sistema operacional (regedit);
2. Procure pelo registro TOTVS, conforme print acima;
3. Edite a chave UltimoPatchFullInstalado clicando 2x sobre ele ou clicando com botão direito selecionando Modify;
4. Informe o valor da última versão específica, cuja instalação foi completa (Instalação Normal);
5. Clique em OK para aplicar essas alterações e saia do Gerenciador de Registros. Execute novamente o instalador do patch e selecione Instalação Granular.

Veja que agora serão listados os itens ainda não instalados corretamente.

mceclip2.png

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