Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS Backoffice (Linha Protheus) - ADVPL - Erro: cannot resolve the collation conflict

time.pngTempo aproximado para leitura: 00:02:00 min

Ocorrência
Estou fazendo uma query em uma customização utilizando dois bancos com colações (collations) diferentes, e ao executar o comando é gerado o seguinte erro:

Cannot resolve the collation conflict between "Latin1_General_BIN" and "SQL_Latin1_General_CP1_CI_AS" in the equal to operation.


Ambiente
Cross Segmentos - Backoffice (Linha Protheus) – ADVPL – A partir da versão 11.8

Causa
Este erro ocorre quando são utilizados bancos com colações diferentes (construídos com configurações diferentes) para efetuar um instrução de junção (join).

A colação é a codificação de caracteres existente no banco de dados (semelhante ao encoding).

Solução
Verificar se a empresa fabricante do banco de dados disponibiliza alguma função de conversão de colação.

Exemplo

SELECT 
SB1.B1_COD, SB1.B1_DESC,
SB1.B1_TIPO, SB5.B5_CEME
FROM
SB1990 AS SB1
LEFT JOIN
SB5990 AS SB5
ON SB1.B1_COD COLLATE Latin1_General_CI_AI = SB5.B5_COD COLLATE Latin1_General_CI_AI
ORDER BY
SB1.R_E_C_N_O_ DESC;
GO
Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _