Ocorrência
Ao gerar a nota de saída(Mata461), o sistema está informando o help : A461NUMNF - Falha na reserva do próximo número disponível da SD9 .
Ambiente
Microsiga Protheus - a partir da versão 11.
Causa
O controle de numeração por SD9 foi desenvolvido baseado no modelo de Talão de Notas. São criados na SD9 um Lote de 5.000 numerações (ou "formulários" teoricamente) para serem utilizados/consumidos no faturamento.
O sistema gera a mensagem A461NUMNF, quando o talão foi consumido e está tentando criar um novo talão com mais 5000 numerações, mas, por alguma inconsistência no processo, o talão não é gerado. Como excede o número de tentativas para gerar o talonário ocorre a mensagem em questão.
Solução
Para ajustar a numeração:
1 - Realize backup da tabela , e execute a rotina de Ajuste de Numeração da tabela SD9 (MATA470 - verifique orientações do Boletim) para corrigir o controle de numeração. O boletim se encontra na Faq FAT0049 Controle de Numeração de Documento de Saída no Protheus -> etapa - 3. Para controle por SD9.
2-Se ainda sim o problema persistir, valide se a rotina MATA461 não precisa de atualização e baixe um pacote mais atual no portal do cliente, opção downloads, pacotes disponíveis ,caso não haja, entre em contato com o Suporte Técnico Protheus.
3- Outra situação que pode ocorrer a mensagem é erro no índice da SD9. Neste caso, a tabela SD9 precisa conter os índices conforme abaixo para que a mensagem não ocorra:
0 Comentários