Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Backoffice RM - BI - Registros duplicados no cadastro de Consulta SQL

time.png Tempo aproximado para leitura: 00:01:53 min

Ocorrência
Acessando o produto na aba Gestão, ao abrir o cadastro de Consulta SQL os registros são todos retornados de forma Duplicada. No exemplo abaixo foi solicitado ao sistema que retornasse apenas as consultas SQL cadastradas para o Educacional.

mceclip0.png


Ambiente
Cross Segmentos - TOTVS Backoffice (Linha RM) - RM BI – Todas as versões

Causa
Esse incidente ocorre porque na base de dados, tabela GCONSSQL, existem cadastros de consultas SQL com valores diferentes na coluna APLICACAO, para a mesma aplicação.

Exemplo:

Coluna APLICACAO preenchida com letra 's' minúsculo em vez de 'S' maiúsculo.

Solução
Para solucionar essa ocorrência, padronize a informação no banco de dados de forma que os registros constem, TODOS, com valor em maiúsculo ou minúsculo.

OBSERVAÇÃO: por padrão o sistema RM grava essa informação com valor sempre em maiúsculo.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _