Tempo aproximado para leitura: 00:01:53 min
Ocorrência
Acessando o produto na aba Gestão, ao abrir o cadastro de Consulta SQL os registros são todos retornados de forma Duplicada. No exemplo abaixo foi solicitado ao sistema que retornasse apenas as consultas SQL cadastradas para o Educacional.
Ambiente
Cross Segmentos - TOTVS Backoffice (Linha RM) - RM BI – Todas as versões
Causa
Esse incidente ocorre porque na base de dados, tabela GCONSSQL, existem cadastros de consultas SQL com valores diferentes na coluna APLICACAO, para a mesma aplicação.
Exemplo:
Coluna APLICACAO preenchida com letra 's' minúsculo em vez de 'S' maiúsculo.
Solução
Para solucionar essa ocorrência, padronize a informação no banco de dados de forma que os registros constem, TODOS, com valor em maiúsculo ou minúsculo.
OBSERVAÇÃO: por padrão o sistema RM grava essa informação com valor sempre em maiúsculo.
0 Comentários