FAQs - Suporte técnico

RH - Linha Protheus - GPE - Ao executar a Contabilização de Folha Apresenta Error.log - Number of locks exceeded - Total: 10000


Ocorrência

Ao executar a rotina de contabilização da folha (GPEM110) com o Appserver Build 19.3.1.0 ou 19.3.1.1, o sistema está apresentando os seguintes erros: "Number of locks exceeded - Total: 10000  on RECLOCKED(APLIB060.PRW)" ou "Number of locks exceeded - Total: 10000 on MSRLOCK(APLIB060.PRW)"

Ambiente: 
TOTVS RH - TOTVS RH (Linha Protheus) - Gestão de Pessoal Todas as versões

Causa
O erro ocorre por problemas no controle de Locks em transações de Banco de dados para as versões do Appserver Build 19.3.1.0 ou 19.3.1.1

Solução
Para erros dessa forma, existe a definição de limite no arquivo de configuração do Servidor de Aplicação (apperver.ini), através da chave MAXLOCKS.
Para isso, inclua em seu appserver.ini, na sessão [Environment], a chave de acordo com o exemplo abaixo:
[Environment]
...
maxLocks=100000
...
Além da configuração do APPSERVER.INI,  também será necessário a atualização de binário, conforme abaixo:
https://suporte.totvs.com/portal/p/10098/download#000006/368/TFAPP/

Informações complementares
Boletim técnico sobre a Chave MaxLocks: https://tdn.totvs.com/display/tec/MaxLocks
Pacote Expedição Contínua RH: MP - GPE - Como fazer o download (baixar) do pacote de expedição continua (acumulado) do modulo Gestão de Pessoal
Pacote Acumulado e-Social: https://centraldeatendimento.totvs.com/hc/pt-br/articles/360051585234

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _