Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS Backoffice (Linha Protheus) - ADVPL - Erro no ParseURL TWSDLSManager

time.pngTempo aproximado para leitura: 00:02:00 min

Ocorrência

Problemas com a classe TWSDLManager utilizando o método ParseURL(). 
"Can't create file name: 80 
Can't open file 1.: Invalid argument"

Mesmo verificando todas as permissões de pastas e compartilhamento de rede o erro persiste. 

Ambiente
Cross Segmentos - Backoffice (Linha Protheus) – ADVPL – A partir da versão 11.80

Causa
Se o binário do protheus for 32 bits o erro ocorre quando a pasta SysWOW64 está muito cheia
Se o binário do protheus for 64 bits o erro ocorre quando a pasta System32 está muito cheia. 

Quando essa pasta (C:\Windows\SysWOW64)  esta acima dos 65 mil arquivos o TWSDLManager só funciona com o server em modo console, apagando os arquivos (.tmp) da pasta ele volta a funcionar como serviço


Solução
Para solucionar essa ocorrência, realize os seguintes passos:
Deletar os arquivos .tmp destas pastas

Esse artigo foi útil?
Usuários que acharam isso útil: 3 de 3

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _