Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - TEC - No SQL servers are available

relogio.png Tempo aproximado para leitura: 00:01:00 min

Ocorrência

No arquivo de log do banco de dados apresenta a mensagem 8839: No SQL servers are available.

Ambiente
Framework - Framework (Linha Datasul) - Progress OpenEdge – Todas as versões

Causa
O número de conexões do tipo SQL no banco está abaixo do necessário para o produto Datasul.

Solução
Para correção do erro, execute o procedimento abaixo nos bancos que apresentarem o erro:

1. Edite o script de carga do banco;
2. Aumente o número de conexões alterando o valor do parâmetro -Mpb e -Ma do broker SQL;
3. Ajuste os valores para os parâmetros: -Mn, -n;
4. 
Reinicie o banco para assumir os novos valores.

Importante
Segue descritivo dos parâmetros de conexão estabelecidos no script de carga dos bancos:

-Mpb: quantidade de servidores por broker 4GL/SQL;
-m3: indica que possui um broker adicional para o banco de dados;
-Mn: quantidade de servidores por banco de dados. Esse valor deve contemplar a quantidade de servidores dos broker 4GL, broker SQL, e adicionais;
-Ma: quantidade de conexões por servidor; 
-Mi: quantidade mínima de conexões que um servidor precisa receber antes de abrir/carregar/habilitar um novo servidor; 
-n: quantidade de conexões no banco de dados. Esse valor deve contemplar a quantidade de conexões no broker 4GL, a quantidade de conexões no broker SQL e serviços como APW, BIW e WDOG.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _