FAQs - Suporte técnico

RM - Frame - Erro ao instalar Biblioteca RM / Código de erro do sistema: 2

Ocorrência
Ao instalar Biblioteca RM, é apresentado o erro abaixo:

Erro ao criar arquivo temporário necessário a esta instalação. Pasta: C:\User\Public\Desktop\. Código de erro do sistema: 2



Ambiente
RM – Framework – Todas as versões do RM. 

 

Causa
Esse erro pode ser apresentado ao realizar a instalação utilizando um instalador que pode ter sido corrompido ao realizar o download do mesmo; falta de permissão (credenciais) para execução do instalador, ou ainda, em alguns casos, especificamente para o Windows 10, falta de atualizações do Windows ou arquivos ausentes.

 

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

  1. Realize o download do instalador novamente, no Portal do Cliente, pois o mesmo pode ter corrompido durante o download. Por exemplo: O instalador da BIBLIOTECARM-12.1.22.MSI, possui 891 MB, avalie o tamanho do arquivo baixado;
  2. Logue na máquina com usuário administrador;
  3. Salve o instalador no diretório C:\, por exemplo, ou diretório com permissões;
  4. Execute o instalador como administrador;
  5. Reinicie a máquina;
  6. Caso a inconsistência persista, realize o teste de instalação em outra máquina para isolar se o erro trata-se de falha no ambiente ou no instalador;
  7. Tendo êxito na instalação em outra máquina, poderá verificar se na primeira máquina falta atualizações do Windows ou arquivos ausentes;
    1. Instale atualizações do Windows:
      1. Pressione a tecla Windows + I e selecione Atualização e segurança;
      2. Clique em Verificar atualizações e aguarde;
      3. Quando a lista de atualizações disponíveis for revelada, instale todas elas;
      4. Repita o mesmo procedimento várias vezes para garantir que todas as atualizações necessárias foram instaladas;
      5. Não se esqueça de reiniciar o sistema para concluir a instalação de atualizações.

    2. Restaure ou repare os arquivos ausentes:
      1. Clique com o botão direito do mouse no botão Iniciar e selecione "Prompt de Comando (Admin)";
      2. Digite "sfc /scannow" na janela do prompt de comando e pressione Enter para executar uma verificação completa do sistema;
      3. Deixe o prompt de comando para executar - isso pode levar entre 5 a 10 minutos.
      4. Se tudo correr bem, você recebera a mensagem: "A Proteção de Recursos do Windows não encontrou nenhuma violação de integridade".
      5. Se você vir uma mensagem "A Proteção de Recursos do Windows encontrou arquivos corrompidos e os reparou com êxito", isso indica que você reparou com êxito arquivos de sistema ausentes ou corrompidos no Windows 10 com SFC.

  8. Realize a instalação da Biblioteca RM novamente.
Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _