Tempo aproximado para leitura: 00:02:00 min
Ocorrência
Ao vincular um item que vai para beneficiamento com a OP usando o botão Beneficia do pedido de vendas é gerado errorlog: array out of bounds ( 0 of 101 ) on A410REMBEN(MATN410A.PRW).
Ambiente
Cross Segmentos-TOTVS Backoffice (Linha Protheus)- SIGAFAT - a partir da versão 12.
Causa
O erro ocorre por o campo C6_QTDLIB2 está com o uso desmarcado.
O erro também pode ocorrer com os campos C6_PRODUTO, C6_TES, C6_LOCAL, C6_ITEM, C6_QTDVEN, C6_UNSVEN, C6_LOTECTL, C6_NUMLOTE, C6_DTVALID, C6_LOCALIZ, C6_NUMSERI, C6_QTDLIB, C6_QTDLIB2, C6_PRCVEN e C6_VALOR, pois todos estes campos fazem parte do array da rotina A410REMBEN.
Se o nível de campo dos campos que compõem o array ,estiver diferente do padrão que é 1, ou a houver falta de um dos campos que fazem parte do array, no Dicionários de Dados, também gerará o erro de array da função A410REMBEN,
Solução
Via configurador, Dicionário de Dados, alteração da tabela SC6 - itens de pedido de vendas, localize o campo em questão, marque-o como usado e valide se o nível do campo está igual a 1, não estando, ajuste-o também.
Salve a alteração do campo e da tabela, atualize o dicionário de dados, reinicie o smartclient e efetue o pedido novamente.
Para o caso de falta de campo no Dicionário de Dados, é necessário efetuar o download do Dicionário de Dados no portal do cliente, conforme a sua release de uso e posteriormente, processar o UPDDISTR para que o ambiente assuma a atualização de Dicionário de Dados.
Feito o procedimento, reinicie o Protheus e efetue o processo novamente.
0 Comentários