Ocorrência
Ao realizar o retorno de pagamento CNAB através da rotina FINA430 é apresentado a informação de que o arquivo está corrompido de acordo com os parâmetros bancos.
Ambiente
Cross Segmento - Backoffice Linha Protheus – Financeiro – A partir da versão 12.1.17
Causa
A mensagem é apresentada pois a rotina realiza validação do arquivo de retorno e do cadastro de Parâmetros Bancos deste banco, agencia, conta e subconta. Ou seja, caso o arquivo de configuração utilizado esteja com número de bytes diferente do que foi configurado no cadastro Parâmetros Banco para o Banco informado nos parâmetros da rotina, o sistema exibirá a mensagem "Arquivo Corrompido".
Por exemplo: Quando o arquivo de retorno é modelo 2 (240 bytes) e no cadastro de parâmetros bancos o número de bytes está com o conteúdo 400(modelo 1).
Solução
Verificar se o cadastro Parâmetros de Banco foi configurado com o numero de Bytes correto e se o Banco, agencia, conta e subconta informados na rotina de processamento de retorno CNAB (FINA430) estão corretos (acordo com o arquivo modelo utilizado).
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