Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.
Base de Conhecimento

Cross Segmento - Backoffice Linha Protheus - ADVPL - Ponto de entrada FA090SE5 não funciona

Cross Segmento - Backoffice Linha Protheus - ADVPL - Ponto de entrada FA090SE5 não funciona

time.pngTempo aproximado para leitura:00:01:00 min

Ocorrência
Estou utilizando o ponto de entrada FA090SE5, porém o mesmo não funciona.

Ambiente
Cross Segmento - Backoffice (Linha Protheus) – ADVPL – A partir da versão 12.1.17

Causa
Esse incidente ocorre, pois a houve mudança no ponto FA090SE5, não é possível mais utilizar a reclock é necessário retornar a variável com a string a ser gravada.

Solução
Segue exemplo conforme documentação.

#include 'protheus.ch'
#include 'parmtype.ch'

User function FA090SE5()

Local cNumero := SE2->E2_NUM
Local cPrefixo := SE2->E2_PREFIXO
Local cParcela := SE2->E2_PARCELA
Local cFornece := SE2->E2_FORNECE
Local cLoja := SE2->E2_LOJA
Local _CMOTBX := CMOTBX //Motivo de Baixa

Local cHistor := ""

IF _CMOTBX = "DEBITO CC"
cHistor := cPrefixo+cNumero+cParcela+cFornece+cLoja
END

Return(cHistor)


Saiba mais
DT_FA090SE5_Grava_dados

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 1

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _