Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS Backoffice (Linha Protheus) - ADVPL - Erro: queries com a declaração with

time.pngTempo aproximado para leitura: 00:03:00 min

Ocorrência
Quando utilizado funções de execução de query no banco e a declaração de pesquisa contém o comando WITH, está sendo gerado erro em tempo de execução:

A função ChangeQuery não pode ser utilizada para queries com a palavra reservada WITH. on CHANGEQUERY(APLIB070.PRW)


Ambiente

Cross Segmentos - Backoffice (Linha Protheus) – ADVPL – A partir da versão 12.1.17

Causa
A função ChangeQuery() não reconhece queries que contenham a palavra WITH, por isso a mesma entrava em loop.

Como a mesma não é homologada para trabalhar com queries que utilizem a declaração WITH, ela passou a verificar a existência do comando na query enviada e gerar exceção (error.log) informando que não está apta a trabalhar com queries deste tipo.

Solução
Não utilizar a função ChangeQuery() e nem funções que trabalhem com ela internamente.

Uma das funções que pode ser utilizada com a declaração WITH é a TcGenQry().

Saiba mais
TCGENQRY

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _