Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.
Base de Conhecimento

Cross Segmentos - Backoffice RM - BI - Rm.Lib.Gerador.Execute parou de funcionar

Cross Segmentos - Backoffice RM - BI - Rm.Lib.Gerador.Execute parou de funcionar


time.png
 Tempo aproximado para leitura: 00:02:47 min

Ocorrência
Ao tentar acessar a Visão Delphi através da aba Gestão | Gerador de Relatórios  é exibido a mensagem de erro RM.Lib.Gerador.Execute parou de funcionar


Ambiente

Cross Segmentos - TOTVS Backoffice (Linha RM) - RM BI - Todas as versões

Causa
Esse incidente ocorre após realizar a instalação de patches recentes que requerem que a conexão ODBC através do SQL Server Native Client 11.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:

1. Acesse o BDE Administrator, clique sobre a conexão principal CorporeRM com a base de dados e observe se o tipo da conexão trata-se de MSSQL ou SQL Server, caso seja, gentileza renomear a conexão CorporeRM para CorporeRM_bkp por segurança e salve as configurações no ícone Apply

 

                          KCS1.png

 

                           mceclip0.png

 

2. Prossiga com a instalação do driver SQL SERVER NATIVE CLIENT 11 que se encontra anexado no artigo e configure sua conexão ODBC conforme documento RM - BD - Como configurar uma conexão ODBC (SQL Server 2012 e superiores) com o mesmo nome da conexão anterior.


3. Reinicie o BDE e em seguida realize os devidos testes. Este procedimento deverá ser realizado em todas as máquinas que apresentarem a inconsistência, em caso de ambiente 3 camadas, deverá ser realizado tanto nos Servidores quando nos Clients.

Em anexo encontra-se o SQL Server Native Client 11 64 e 32 bits.

 

Importante
Para base de dados Oracle siga os passos 2 e 3 e siga o seguinte artigo: RM - BD - "BDE - Instalação e Configuração ORACLE"

Saiba mais
Esse procedimento pode solucionar também os erros: Visão Delphi não abre e Exceção EOleException no módulo RMGerador.dll em 00176762.

 

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 5 de 5

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _