FAQs - Suporte técnico

Cross Segmento - TOTVS Backoffice Linha Protheus - ADVPL - Erro rotina automatica FINA040

Ocorrência
A rotina automática FINA040, não está sendo executada quando E1_TIPO = 'RA'. esta retornando erro: 

Screenshot_17.png

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) – Financeiro – A partir da versão 11.80

Causa
Esse incidente ocorre, pois os campos de BancoAgência e Conta devem ser informados obrigatoriamente pelos rótulos CBCOAUTOCAGEAUTO e CCTAAUTO, presentes no array utilizado na chamada da ExecAuto.

Se essas variáveis não estiverem presentes no array, o título não será incluído.

Se forem informadas vazias ou com conteúdos que não existem na tabela de cadastro de bancos (SA6), o título será invalidado e também não será incluído no sistema.



Solução

/* Exemplo 01: Forma correta para informar os campos para Inclusão de um título de tipo RA que gera movimentação bancária.*/
//Teste de inclusão

#INCLUDE "PROTHEUS.CH"
#INCLUDE "TBICONN.CH"

User Function FIN040INC()

LOCAL aArray := {}

PRIVATE lMsErroAuto := .F.

PREPARE ENVIRONMENT EMPRESA "T1" FILIAL "D MG 01" MODULO "FIN" TABLES "SE1","SE5","SA1","SA2"

Conout("----Inicio da Rotina Automatica!------")

aArray := { { "E1_PREFIXO"  , "AUT"             , NIL },;
            { "E1_NUM"      , "000004"          , NIL },;
            { "E1_TIPO"     , "RA"              , NIL },;
            { "E1_NATUREZ"  , "000001"          , NIL },;
            { "E1_CLIENTE"  , "000001"          , NIL },;
            { "E1_LOJA"     , "01"              , NIL },;
            { "E1_EMISSAO"  , CtoD("06/07/2018"), NIL },;
            { "E1_VENCTO"   , CtoD("06/07/2018"), NIL },;
            { "E1_VENCREA"  , CtoD("06/07/2018"), NIL },;
            { "CBCOAUTO"    , "341"             , NIL },;
            { "CAGEAUTO"    , "0001"            , NIL },;
            { "CCTAAUTO"    , "00001"          , NIL },;
            { "E1_VALOR"    , 600               , NIL }}

MsExecAuto( { |x,y| FINA040(x,y)} , aArray, 3)  // 3 - Inclusao, 4 - Alteração, 5 - Exclusão

If lMsErroAuto

    MostraErro()

Else
    Conout("Título incluído com sucesso!")
Endif

RESET ENVIRONMENT

Return

/* Exemplo 02: Forma incorreta para informar os campos para Inclusão de um título de tipo RA que invalidará a inclusão do título.*/
//Teste de inclusão

#INCLUDE "PROTHEUS.CH"
#INCLUDE "TBICONN.CH"

User Function FIN040INC()

LOCAL aArray := {}

PRIVATE lMsErroAuto := .F.

PREPARE ENVIRONMENT EMPRESA "T1" FILIAL "D MG 01" MODULO "FIN" TABLES "SE1","SE5","SA1","SA2"

Conout("----Inicio da Rotina Automatica!------")

aArray := { { "E1_PREFIXO"  , "AUT"             , NIL },;
            { "E1_NUM"      , "000006"          , NIL },;
            { "E1_TIPO"     , "RA"              , NIL },;
            { "E1_NATUREZ"  , "000001"          , NIL },;
            { "E1_CLIENTE"  , "000001"          , NIL },;
            { "E1_LOJA"     , "01"              , NIL },;
            { "E1_EMISSAO"  , CtoD("06/07/2018"), NIL },;
            { "E1_VENCTO"   , CtoD("06/07/2018"), NIL },;
            { "E1_VENCREA"  , CtoD("06/07/2018"), NIL },;
            { "CBCOAUTO"    , ""             , NIL },;
            { "CAGEAUTO"    , ""            , NIL },;
            { "CCTAAUTO"    , ""          , NIL },;
            { "E1_VALOR"    , 600               , NIL }}

MsExecAuto( { |x,y| FINA040(x,y)} , aArray, 3)  // 3 - Inclusao, 4 - Alteração, 5 - Exclusão

If lMsErroAuto

    MostraErro()

Else

    Conout("Título incluído com sucesso!")

Endif

RESET ENVIRONMENT

Return



Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _