Tempo aproximado para leitura: 00:01:32 min
Ocorrência
O que fazer caso no log do JBoss ocorra o erro StackOverflowError?
Ambiente
Datasul – Portal HCM – Versão 12
Causa
O erro de StackOverflowError pode ter várias causas, abaixo seguem algumas informações que devem ser analisadas para solução desta mensagem:
Apagar as pastas temporárias do JBoss: Pare o JBoss e apague as pastas work, tmp, log e data. Em seguida, deve-se reiniciar o JBoss.
Conferir memória da JVM: Caso não se tenha sucesso com a solução passada na primeira alternativa, então pode-se aumentar o parâmetro de memória da JVM para no mínimo 256mb - parâmetros –Xms e –Xmx. Após esta alteração, pode-se fazer o primeiro procedimento novamente.
O JBoss pode não iniciar se estiver apontando para um Java 32 bits ao alocar mais memória para a JVM. Em caso de dúvidas referente a execução dos procedimentos citados, é possível acionar a consultoria de banco de dados para acompanhamento.
Se executados os procedimentos citados e ainda assim o erro persistir, deve-se abrir um ticket para o módulo Portal HCM enviando as seguintes informações:
- Documento ou vídeo detalhando o processo efetuado, até apresentar a mensagem.
- Log do JBoss após simular a mensagem informando qual a data/hora em que a mensagem ocorreu.
- Um print screen da tela de serviços do Windows, clicando com o botão direito no serviço do JBoss.
- Na tela anterior, em Path to Executable mostra o diretório de instalação do JBoss. É necessário enviar o arquivo service-<instância>.bat e run.bat.
0 Comentários