Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - TOTVS Backoffice Linha Protheus - ADVPL - Mensagem Help: FWMODELPOS modelo inválido ponto de entrada FT300VLD

time.pngTempo aproximado para leitura: 00:02:00 min

Ocorrência
No ponto de entrada FT300VLD quando o retorno é falso (.F.), aparece uma mensagem

Help: FWMODELPOS

Problema: Modelo inválido.

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) – ADVPL – Todas as versões

Causa
Ao retornar .F. nas validações MCV

Solução
O Help é padrão do MVC e neste caso precisa ser tratado, pois ao executar pontos de entrada em rotinas MVC e retornar false o formulário, será gerado obrigatoriamente um Help.

Essa mensagem é possível de ser customizada, exemplo:

#Include 'Protheus.ch'

User Function FT300VLD()
lRet := .F.

Help("",1,"FT300VLD",,"seu texto",1) // "Preencher o campo Loja do Prospect."

Return(lRet)

 

 

Saiba Mais
Cross Segmento - Backoffice Linha Protheus - ADVPL - Tratamento help ponto de validação MVC

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 1

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _