Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - Backoffice (Linha Protheus) - SIGAEST - BLOCO K - ERROLOG THREAD ERROR [Microsoft][SQL Server Native Client 10.0][SQL Server]Invalid column name 

Tempo aproximado para leitura:00:01:50 min

 

Ocorrência

No módulo Estoque-Custos, ao tentar realizar a extração do BLOCO K  é apresentado o error.log 

THREAD ERROR [Microsoft][SQL Server Native Client 10.0][SQL Server]Invalid column name 

Error : 207 (S0022) (RC=-1) - [Microsoft][ODBC Driver 11 for SQL Server][SQL Server]Nome de coluna 'OI' inválido.
Error : 207 (S0022) (RC=-1) - [Microsoft][ODBC Driver 11 for SQL Server][SQL Server]Nome de coluna 'PI' inválido.
Error : 207 (S0022) (RC=-1) - [Microsoft][ODBC Driver 11 for SQL Server][SQL Server]Nome de coluna 'SP' inválido.
Error : 207 (S0022) (RC=-1) - [Microsoft][ODBC Driver 11 for SQL Server][SQL Server]Nome de coluna 'PA' inválido.
Error : 207 (S0022) (RC=-1) - [Microsoft][ODBC Driver 11 for SQL Server][SQL Server]Nome de coluna 'PP' inválido.


Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Estoque/Custos - Todas as versões.

 

Causa
Esse incidente ocorre, pois a parametrização usada nos parâmetro a baixo estão sem aspas, ou com aspas incorretas, assim o sistema não entende a funcionalidade do parâmetro e gera-se Error.log

MV_BLKTP00  'PA'
MV_BLKTP01 ''MP'
MV_BLKTP02   PI
MV_BLKTP03
MV_BLKTP04
MV_BLKTP05
MV_BLKTP06
MV_BLKTP10


Solução
Para correção, ajustar o preenchimento dos tipos de produtos, é necessária a utilização do apóstrofo ( ' ) e vírgula ( , ) para seleção de dois ou mais tipos.

Exemplo:

MV_BLKTP00 = 'ME', 'XX', 'YY'.

 

Saiba Mais:
Clique aqui e veja mais artigos sobre Legais no Estoque

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _