Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Manufatura - Linha Protheus - SIGAQIE - Mensagem: Número de códigos reservados maior que 20

time.png Tempo aproximado para leitura: 00:01:20 min

Ocorrência

Ao realizar a inspeção de entrada, por meio da rotina de QIEA215 - Resultados, informando uma FNC - Ficha de Não Conformidade, o Sistema apresenta mensagem Numero de códigos reservados maior que 20.

Ambiente

TOTVS Manufatura - TOTVS Manufatura (Linha Protheus) - Inspeção de Entradas (SIGAQIE) - Todas as versões

Causa
Geralmente a mensagem é apresentada devido a registros deletados na tabela QI2 - Não Conformidades. O controle de numeração automática, por conceito, consegue reservar até 20 números na montagem do código da FNC.

Solução

Para solucionar essa ocorrência, realize os seguintes passos:

1. Verificar em ambiente homologação a existência de registros deletados na tabela de não conformidades - QI2, realizando pack via APSDU

2. Validar o campo Chave - QE_CHAVE se preenchido com o ano corrente. Exemplo: 2019;

3. O campo Tamanho - QE_TAMANHO deve estar preenchido com 11;

4. Verificar se o campo Numero QE_NUMERO já existe no Sistema. Caso sim, ajustar manualmente para o próximo número.
Exemplo: Na tabela QNSXE a próxima numeração está como 00000000174, porém a última FNC que consta no Sistema é a 00000000175. Neste exemplo seria necessário alterar na QNSXE para 00000000176 para resolver o erro. Na tabela QNSXF não é necessária alteração.

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 1

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _