Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - Linha Protheus - TAF - eSocial - Painel eSocial - Erro de schema "No matching global declaration avaivable for the validation root


Dúvida
Ao tentar transmitir os eventos do eSocial, é apresentado erro de SCHEMA:

Erro de schema "No matching global declaration avaivable for the validation root.

 

Exemplo de erro que pode ocorrer para os clientes que estão alterando de leiaute eSocial:

 

Ambiente
TOTVS RH - TOTVS RH (Linha Protheus) - eSocial - TAF eSocial - e-Social - Painel Esocial do Futuro - Todas as versões

 

Causa
Se o cliente estiver com o erro de Schema apresentado acima, independente do leiaute, solução abaixo será a mesma:

 

Solução

Para solucionar essa ocorrência, será necessário alterar o parâmetro MV_TAFVLES para S_01_03_00 ou S_01_02_00 (conforme a atualização e necessidade do cliente) e estar com o TAF e TSS atualizados com os pacotes abaixo:

 

1. Atualização, Expedição Contínua:

Cliente no release 12.1.33, 12.1.2210 e 12.1.2310 , utilizem o link de atualização abaixo, caso não estejam atualizados:

Automação Fiscal - ATUALIZAÇÃO - Como atualizar o TAF E-social (Expedição Contínua)?

 

Atenção: Esta atualização possui dicionário de dados, é necessário rodar o UPDDISTR e UPDTAF.

 

2. Atualizar TSS e Schemas:

Se o ambiente não estiver atualizado, TSS e Schemas, utilize a documentação abaixo, que contém todos os links necessários:

Automação Fiscal - ATUALIZAÇÃO - Links para atualizar o TSS - Transmissão de Documentos Eletrônicos 

 

5. Alterar o parâmetro MV_TAFVLES no TAF:

Link para orientação:

Automação Fiscal - ATUALIZAÇÃO - Como atualizar a versão do layout no TAF E-social?

 

ATENÇÃO: Para clientes que realizam a integração com o SIGAGPE, será necessário alterar também o parâmetro MV_VLESOC.

 

OBSERVAÇÃO:

Se o registro (evento) no TAF, foi integrado em um leiaute diferente do configurado no parâmetro MV_TAFVLES, será necessário excluir o evento no TAF e integrar o registro novamente do ERP (GPE/RM/Datasul) para o TAF;

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

3 Comentários

  • Avatar
    Gabriela Jorge Vieira

    Olá, essa solução é para as versões 11.80 até a 12.1.17 após essas versões como devemos tratar o erro?

    O Schema esta atualizado e apresenta a mesma mensagem na versão 12.1.033, como tratar?

     

    -1
    Ações de comentário Permalink
  • Avatar
    ALVARO SANTOS PIMENTA

    Também estou com o mesmo problema, Como Resolver?

    0
    Ações de comentário Permalink
  • Avatar
    Rodrigo Gomes Sobral (Editado )
     
    0
    Ações de comentário Permalink
Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _