Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Framework - Linha Datasul - TEC - Java com horário de verão incorreto

time.png Tempo aproximado para leitura: 00:01:32 min

Ocorrência
Aplicativos executando sobre a JVM Java não estão de acordo com a configuração de horário de verão do Sistema Operacional.

Ambiente
Framework - Framework (Linha Datasul) - JBoss - Java 1.7

Causa
O Java possui um DST Dayligth Saving Time próprio e nesse caso é necessário atualizar o seu banco de dados local com as informações de TimeZone mais recentes.

Solução
Siga os passos a seguir:
1. Efetue o download da última versão do banco de dados de TimeZone neste link:
Time Zone Database. 
Pode ser efetuado o download do arquivo Data Only Distribution.

2. Efetue o download da ferramenta de atualização dessas informações:
Java SE TZUpdater Downloads 
Extraia do arquivo compactado o arquivo tzupdater.jar.

3. Copie os arquivos tzupdater.jar e o tzdata*.tar.gz para um diretório temporário qualquer, como por exemplo c:\temp

4. Configure as variáveis de ambiente JAVA_HOME e PATH, exemplo:
set java_home="c:\Program Files\Java\jdk11"
set path=%java_home%\bin;c:\windows\System32

5. Acesse o prompt de comandos, cmd ou telnet conforme Sistema Operacional, como administrador e execute:
java -jar c:\temp\tzupdater.jar -v -f -l file:c:\temp\tzdata2024b.tar.gz

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 1

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _