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Cross Segmentos - TOTVS Backoffice (Linha RM) - Doc. Eletrônicos - 539/Rejeição: Duplicidade de NF-e com diferença na Chave de Acesso

Cross Segmentos - TOTVS Backoffice (Linha RM) - Doc. Eletrônicos - 539/Rejeição: Duplicidade de NF-e com diferença na Chave de Acesso

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Ocorrência
No módulo TOTVS Gestão de Estoque, Compras e Faturamento, ao consultar a autorização da NF-e a mensagem de rejeição abaixo é exibida pela SEFAZ (Secretaria de Estado da Fazenda): 

539/Rejeição: Duplicidade de NF-e, com diferença na Chave de Acesso

Ambiente 
Cross Segmentos - TOTVS Backoffice (Linha RM) - Documentos Eletrônicos - NFE - A partir da versão 12.1.17

Causa 
Quando for emitida uma NF-e e na Sefaz já existir outra NF-e, já autorizada, com o mesmo CNPJ Emitente, Modelo, Série e Número, mas com, Data de Emissão, Tipo de Emissão ou Código Numérico ou outras posições da Chave de Acesso diferentes, será realmente exibida a rejeição.

Solução
Para adequar a situação, é necessário observar se a nota que consta na SEFAZ como autorizada, contém o mesmo conteúdo da nota que está sendo rejeitada.

1° - Se o conteúdo for o mesmo, será acertar os dados da autorização da nota fiscal via banco de dados. Para tal, altere o campo Status para 'A'; no campo XMLNFE insira o XML da autorização da nota fiscal baixado do portal da Sefaz; acerte o campo CHAVEACESSO com a chave autorizada na Sefaz e altere o campo PROTOCOLO com a informação do protocolo do portal. Todas as alterações deverão ser realizadas na tabela TNFEESTADUAL. Segue consulta SQL como base das alterações que precisam ser realizadas.

  • SELECT STATUS, XMLNFE, CHAVEACESSO, * FROM TNFEESTADUAL
    WHERE IDMOV = 'ID DO MOVIMENTO'
    AND CODCOLIGADA = 'CÓDIGO DA COLIGADA EM QUESTÃO'

 

2° - Caso não seja o mesmo conteúdo, basta alterar o número do movimento e utilizar outra numeração para o envio.

3° - Caso não consiga localizar no site da SEFAZ através do número da NF-e, realize o seguinte procedimento:

  • Na máquina onde o TSS está instalado, vá em C: - TOTVSSPED - BIN - APPSERVER - APPSERVER.INI:
  • Abaixo da linha [SPED], inclua a seguinte linha de comando:
    SPED_SAVEWSDL=1

** irá salvar o XML trocado entre o TSS e a SEFAZ/Prefeitura na pasta System.

  • Feito isso, realize novamente o envio da NF-e. Neste momento, ela será novamente rejeitada. Contudo, dentro da pasta system (C: - totvssped - system) no arquivo .RCV será informada a chave de acesso da nota que consta autorizada no site da SEFAZ.

Importante
Veja regra de validação da Sefaz:

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2 Comentários

  • Avatar
    Lucas Correa (Editado )

    PÉSSIMO ARTIGO!
    A SOLUÇÃO PARA ESSA NÃO CONFORMIDADE SE PASSA POR UMA MARRETA NO BANCO DE DADOS, E NÃO TRATA A ORIGEM DO ERRO.

    -1
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  • Avatar
    Administrador TI

    Concordo com oque o Lucas informou, o artigo mostra apenas marratar o XML, ou seja, o problema ainda pode ocorrer no futuro. 

    TOTVS sendo TOTVS. 

    0
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