FAQs - Suporte técnico

Cross Segmentos - TOTVS Backoffice (Linha Protheus) - SIGACRM - array out of bounds (0 of 12) on FT300GRV

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Ocorrência

Ao finalizar um atendimento call center com integração com oportunidade de venda, gera o erro: array out of bounds ( 0 of 12 ) on FT300GRV(FATA300.PRX).


Ambiente

Cross Segmentos - TOTVS Backoffice (Linha Protheus) -SIGACRM - a partir da versão 11.


Causa

O erro indica que o sistema está buscando um campo em uma posição do array e não está encontrando, indicando a posição zero, isso pode indicar que o(s) campo(s) envolvido(s) no processo, não está (estão) em uso.

Solução

Avalie se os campos AIJ_PROVEN e AIJ_STAGE estão em uso e com nível 1 , no Configurador, caso não estejam, marque-os como usado , deixe o nível de campo como 1 ,salve a tabela  e atualize o dicionário de dados.

Reinicie o Smartclient e efetue o processo novamente.
 

Importante - Para  a atualização do ambiente na falta de algum campo de tabela é necessário efetuar o download do Dicionário de Dados no portal do cliente, conforme a sua release de uso e posteriormente, processar o UPDDISTR para que o ambiente assuma a atualização de Dicionário de Dados.

Feito o procedimento, reinicie o Protheus e efetue o processo novamente.

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Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

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Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

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Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

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