Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Backoffice Protheus - SIGATMK - Erro na consulta genérica da tabela SU5

Ocorrência

Ao efetuar a consulta genérica da tabela SU5, gera o erro: type mismatch on + on {||Posicione("SX5",1,xFilial("SX5")+'AX'+M->U5_TRATA,"X5_DESCRI")

Ambiente

Cross Segmentos - Backoffice Protheus - SIGATMK - A partir da release 12

Causa

O erro ocorre por que na estrutura do posicione, contida no X3_INIBRW e X3_RELAÇÂO do campo U5_TRATADE, existe uma variável de memória (M) para atribuição de campo U5_TRATA, só é possível utilizar uma variável de memória, quando se está dentro da tabela, neste caso em específico, é preciso utilizar a chamada da própria tabela SU5 para não gerar o erro na consulta genérica.

Solução

A correção encontra-se em dicionário de dados disponibilizado no portal do cliente, basta efetuar o download do dicionário, descompactar o arquivo na pasta system e rodar o upddistr no programa inicial do Protheus.

De forma paliativam efetue a seguinte alteração:

  • De: posicione("SX5",1,XFILIAL("SX5")+"AX"+M->U5_TRATA,"U5_DESCRI") 
  • Para: posicione("SX5",1,XFILIAL("SX5")+"AX"+SU5->U5_TRATA,"U5_DESCRI") 

A informação deverá ser alterada tanto no X3_INIBRW quanto no X3_RELAÇÂO da tabela.

 

 

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _