Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - TOTVS Backoffice Linha Protheus - ADVPL - Erro: invalid classe twebchannel e twebengine

time.pngTempo aproximado para leitura: 00:02:00 min

Ocorrência

Ao tentar utilizar as classes de comunicação mobile TWebChannel() ou TWebEngine() é exibido o seguinte erro no console do AppServer (Application Server):

invalid class TWEBCHANNEL on U_WEBENGINE(WEBENGINE.PRW) 

invalid class TWEBENGINE on U_WEBENGINE(WEBENGINE.PRW) 


Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) – ADVPL – A partir da versão 11.8

Causa
O erro ocorre pois a classe ainda não esta disponível no binário atual:



Solução
A classe está disponível apenas no AppServer Lobo-Guará, de 64 bits, a partir do release do Protheus 12.1.23.

Saiba mais
TWEBENGINE
TWEBCHANNEL
Novo Binário: AppServer Lobo-Guará

 

Esse artigo foi útil?
Usuários que acharam isso útil: 1 de 4

2 Comentários

  • Avatar
    Marcos Alexandre Melo Saabo (Editado )

    Caros,

    Poderia realizar outro exemplo ?

     

     
     
    0
    Ações de comentário Permalink
  • Avatar
    GIVANILDO ANDRADE LOPES

    Sr. Marcos,

    Esse canal está aberto e é exclusivo para sugestões de melhoria nos artigos. Se mesmo após seguir os passos do artigo tenha encontrado uma inconsistência, abra um ticket no canal de atendimento.

    Em conjunto com você, Cliente TOTVS, desejamos criar artigos de qualidade para agilizar o atendimento e fomentar o autoatendimento.

    0
    Ações de comentário Permalink
Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _