Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - TOTVS Backoffice Linha Protheus - ADVPL - E006_IO_ERROR:Falha durante operação de I/O (BIRT)

time.pngTempo aproximado para leitura: 00:05:00 min

Ocorrência
THREAD ERROR ([XXXX], XXXXXXXX, XXX) XX/XX/XXXX XX:XX:XX

E006_IO_ERROR:Falha durante operação de I/O. Oper: COPYFILE Cod: 430 on BIRTREPORT:PREPARE(BIRTREPORT.PRW) 


Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus)  – ADVPL – A partir da versão 11.80

Causa
O Relatório Birt não encontrou o arquivo .rptdesign

O erro em questão ocorre porque a função FILE está retornando falso não encontrando o arquivo no endereço abaixo:

Veja no seu log o trecho conteúdo da variável CRPTRUN

Exemplo:

CRPTRUN(C):C:\Totvs\WebServer\server\webapps\WebViewer\webapps\webviewer\report\clientemdawmjiyru5wsvjptk1ftlq=20170927093938.rptdesign

 
Solução
No caso relatado acima o caminho do relatório continha duas vezes as pastas "\webapps\webviewer\"

no appserve.ini na seção REPORTSERVICE modifique o caminho e valide o CATALINA_HOME

[REPORTSERVICE]

REPORTWEBSERVERPATH=/

image2016-7-7 18:48:46.png

ATENÇÂO

No Ambiente Linux todas as pastas envolvidas para configuração tanto do sistema Protheus como do TOTVS WebViewer deveram ser minúsculo.

 

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _