Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmento - TOTVS Backoffice Linha Protheus - ADVPL - Variable does not exist CEMPANT on FWCODEMP

time.pngTempo aproximado para leitura: 00:05:00 min

Ocorrência
Estou usando uma customização via schedule e gerou esse erro
THREAD ERROR ([XXXXX], XXXXXXX, THIS)  xx/xx/xxxx  
variable does not exist CEMPANT on FWCODEMP(FWFILIAL.PRW) 

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus)  – ADVPL – A partir da versão 11.80

Causa
Esse erro ocorre pois foi utilizada uma função FWCodEmp sem preparar o ambiente.

Solução

Neste caso é necessário preparar o ambiente com a Prepare Environment pois o schedule só agenda a execução.

Exemplo para o agendamento.

#Include 'Protheus.ch'
#Include "tbiconn.ch"

User Function tstfilial()

PREPARE ENVIRONMENT EMPRESA '99' FILIAL '01'
local cfili:= ""
conout("OK")
cfili:= FWCodEmp()
conout("FILIAL " + cfili)

RESET ENVIRONMENT

Return

Saiba mais
FWCodEmp 

Prepare Environment

 

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _