Ocorrência
Ao gerar uma remessa de cobrança no TOTVS Gestão Financeira, o sistema exibe a mensagem abaixo e não conclui a operação:
"Objeto não pode ser convertido de DBNull em outros tipos."
Ambiente
RM – TOTVS Gestão Financeira – A partir da versão 12.1.17.
Causa
Normalmente, observamos este incidente quando o campo 'Aceite' (FBOLETO.CNABACEITE) do Boleto está gravado no banco de dados com valor nulo, sendo que o correto (quando não habilitado) é 0 (zero).
Solução
Deve-se realizar uma Alteração Global do(s) Boleto(s), selecionando o campo Aceite e deixando a opção Valor desmarcada. Assim, a informação será corretamente atualizada no banco de dados, de "NULL" para "0" e a mensagem mencionada não será novamente exibida.
Para realizar a Alteração Global, acesse o menu Contas a Pagar/Receber > Boletos > Localize e selecione o(s) Boleto(s) que será envolvido na remessa e deve ser atualizado > Clique em Processos > Manutenção de Boletos >Alteração Global de Boleto.
Saiba mais
Para mais informações sobre a geração de Boletos e suas operações, clique aqui.
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