Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - TOTVS Backoffice Linha Protheus - ADVPL - Não encontrou o arquivo PRTOPDEF.ch

time.pngTempo aproximado para leitura: 00:02:00 min

Ocorrência
Ao tentar compilar apresenta Warning (Mensagem de Advertência )informando que não encontrou o arquivo: PRTOPDEF.CH



Ambiente
Cross Segmentos - Backoffice (Linha Protheus) – ADVPL – A partir da versão IDE, 11.2 e 11.3

Causa
Não encontrou o arquivo PRTOPDEF.CH na pasta include

Solução
Verifique a pasta bin/includes se contem esse arquivo PRTOPDEF.CH

Caso não encontre baixe do portal de downloads a atualização dos includes

Verifique tambem as propriedades do projeto a configuração do includes

 

Saiba mais
Cross Segmento - TOTVS Backoffice Linha Protheus - ADVPL - TOTVS Development Studio (Descontinuado)

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

18 Comentários

  • Avatar
    Wanderson Fernandes de Souza

    Estou usando o VsCode e esta apresentando esta mesma mensagem, ja reinicei o note verificar novas atualizações do VSCODE e ele não encontra o arquivo. Ja mudei ate o caminho mas não conecta.

     

    Veja que o arquivo encontra-se na pasta

     

     

    0
    Ações de comentário Permalink
  • Avatar
    Mauricio De Arruda Gresele

    como resolveram este problema, estou com o mesmo aqui

    0
    Ações de comentário Permalink
  • Avatar
    Wanderson Fernandes de Souza

    Boa Tarde Mauricio,

       Também estou no aguardo de um posicionamento da TOTVS.

     

    0
    Ações de comentário Permalink
  • Avatar
    Mauricio De Arruda Gresele

    Wanderson boa tarde, instalei a versão anterior da extensão e voltou a funcionar.

    1
    Ações de comentário Permalink
  • Avatar
    Emerson Campos

    Boa tarde,

     

    Também estou com o mesmo erro, o que vc reinstalou?

     

    Att,

     

    1
    Ações de comentário Permalink
  • Avatar
    ARTHUR LOPES LIMA

    Instalem a extensão v1.0.3 do TOTVS Developer Studio for VSCode (AdvPL, TLPP e 4GL) dentro do VS Code!

    1
    Ações de comentário Permalink
  • Avatar
    Diego Felisberto

    Também estou com esse problema, e ai????

    0
    Ações de comentário Permalink
  • Avatar
    Nahim Terrazas Parada

    Boa tarde Gente, 

     

    Aparentemente a versão mais recente tem esse problema:

     

    Tenta instalar uma versão anterior aqui:

     

    Atenciosamente.

     

    Nahim, Bolivia.

     

    2
    Ações de comentário Permalink
  • Avatar
    Jayson Mareco

    Estou com o mesmo problema, mas não encontro versões antigas conforme mostrado!

     

     

    Quem tiver solução avisa aí por favor!!!

    1
    Ações de comentário Permalink
  • Avatar
    GIVANILDO ANDRADE LOPES (Editado )

    Prezados

    Esse canal está aberto e é exclusivo para sugestões de melhoria nos artigos. Se mesmo após seguir os passos do artigo tenha encontrado uma inconsistência, será necessário abrir um ticket no canal de atendimento.

    A documentação é referente ao TDS

    Em conjunto com você, Cliente TOTVS, desejamos criar artigos de qualidade para agilizar o atendimento e fomentar o autoatendimento.

    -5
    Ações de comentário Permalink
  • Avatar
    JULIANO SOUZA

    Desculpe Givanildo, mas precisamos achar soluções as vezes por nós mesmos.

    Pessoal voltem para versão 1.0.3 que resolve.

     

    1
    Ações de comentário Permalink
  • Avatar
    MARCOS BISPO ABRAHAO

    Na versão 1.06 voltou a funcionar.

    0
    Ações de comentário Permalink
  • Avatar
    FERNANDO LUIZ PINHEIRO

    Bom dia. Também estou com o mesmo problema, seja na versão 1.2.0, ou 1.0.6 ou 1.0.3 e qualquer outra... 

    Alguém pode me informar como ajustar o VSCode para compilar?

    Grato

    Pinheiro

    0
    Ações de comentário Permalink
  • Avatar
    Odair Alves de Arruda Junior

    Que perda de tempo... Não funciona...

     

    -1
    Ações de comentário Permalink
  • Avatar
    Karoline Ribeiro

    Consegui resolver fazendo download dos Includes e jogando na pasta includes.

    0
    Ações de comentário Permalink
  • Avatar
    JOSINEY CARRIJO MACHADO

    Aconteceu comigo quando fiz a atualização dos includes, resolvi simplesmente selecionando todos os arquivos da pasta e desmarcando nas propriedades do arquivo, o atributo de somente leitura.

    Com o procedimento acima tudo voltou ao normal e a mensagem desapareceu.

    Abraço...

    0
    Ações de comentário Permalink
  • Avatar
    Thieres Russo de Lima

    No meu caso resolvi indo no próprio VSCode e onde fica o TOTVS servidores, no qual vc cadastrou seu ambiente, clique com o botão direito do mouse e vá em "Configurar a exibição do servidor", depois verifique se na chave dos includes que algum vazio ou caminho errado, no meu caso estava vazio para um dos meus ambientes, ai só preenchi e salvei:

     

    Exemplo: 

    ANTES:

    "includes": [ ],
     
    DEPOIS:
    "includes": [
                    "C:/include"
                ],
    6
    Ações de comentário Permalink
  • Avatar
    Termicom

    A solução do Thieres Russo de Lima funcionou pra mim também.

     

    no começo do arquivo servers.json estava assim:

    {

        "version": "0.2.2",
        "includes": [
            ""
     
    Então alterei para: 

    {

        "version": "0.2.2",
        "includes": [
            "Caminho da pasta Include"
     
     
    2
    Ações de comentário Permalink
Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _