Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

Cross Segmentos - Backoffice Linha Protheus - SIGAFIN - CNAB: Error log array out of bounds pode estar relacionado a Configuração Formato Datas nos Parâmetros Bancos

time.pngTempo aproximado para leitura: 00:03:00 min

Ocorrência

No módulo Financeiro, ao executar o CNAB pode ser exibido o mensagem 
Error log (array out of bounds).

Ambiente
Cross Segmento - TOTVS Backoffice (Linha Protheus) - Financeiro - Todas as versões

Causa
Este erro está relacionado a configuração de forma divergente do esperado pelo sistema. É possível que o erro ocorra devido a configuração do Parâmetros de datas encontrado no campo EE_TIPODAT nos Parâmetros de Bancos.

Solução
Para solucionar essa ocorrência, realize os seguintes passos:
1. Acesse Modulo Financeiro;
2. Selecione Cadastros > Parâmetros de Bancos (FINA130);
3. Edite o campo EE_TIPODAT para as possíveis condições.

EE_TIPODAT.png

Os formatos são:

1 - ddmmaa
2 - mmddaa
3 - aammdd
4 - ddmmaaaa
5 - aaaammdd
6 - mmddaaaa

Importante: 
Verifique no layout do Banco e em seu arquivo de configuração a quantidade de posições, para para adequação do campo data (SEE->EE_TIPODAT) com o número do formato descrito acima.

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 0

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _