Base de conhecimento
Encontre respostas para suas dúvidas em quatro fontes de conhecimento diferentes ao mesmo tempo, simplificando o processo de pesquisa.

RH - RM - FOP - eSocial - Erro de schema ao transmitir XML para o governo

Ocorrência
Ao transmitir o XML para o governo ocorre erro de schema This element is not expected ou is not a valid value of the local atomic type.

Ambiente
TOTVS RH - TOTVS RH (Linha RM) - Folha de Pagamento - eSocial - Todas as versões

Causa
O erro é apresentado quando o XML enviado não está respeitando as regras de schema definidos pelo governo, ou seja, quando a estrutura do XML não está de acordo com o esperado como, por exemplo, alguma tag sem valores ou tag com valor numérico porém o schema de XML não permite valor numérico.

Solução
Para solucionar o erro, siga os passos de validação abaixo:

• '' is not a valid value of the local atomic type

1. Verifique na mensagem do erro apresentada qual a tag inválida. No exemplo abaixo, o erro indica que na tag dia o valor '' (vazio) não é válido;

mceclip1.png

2. Abra os XML do RM e TAF e pesquise pela tag indicada no erro. No exemplo abaixo, de acordo com o erro apresentado no passo 1, a tag dia gerou sem valor sendo assim ocorrerá erro;

mceclip0.png

3. Neste caso, procure o atendimento do RM ou TAF (considerando o XML que está gerando a informação errada) com as evidências para análise. 

 

• 'x' is not a valid value of the local atomic type

1. Verifique na mensagem do erro apresentada qual a tag inválida. No exemplo abaixo, o erro indica que na tag codIncCP o valor '0' não é válido;

mceclip1.png

2. Abra os XML do RM e TAF e pesquise pela tag indicada no erro. No exemplo abaixo, de acordo com o erro apresentado no passo 1, a tag codIncCP gerou valor 0, porém a tag precisa ser gerada como 00 (dois caracteres) conforme definição do leiaute;

mceclip3.png

3. É importante verificar no leiaute do eSocial que tipo de informação e a quantidade de caracteres necessárias conforme descrição modelo abaixo;

mceclip7.png

mceclip5.png

mceclip6.png

4. Verifique no Mapeamento do eSocial a origem da tag. Sendo uma informação preenchida pelo usuário, corrija o campo preenchido no sistema. Sendo uma informação gerada internamente pelo sistema, acione o atendimento técnico com as evidências para análise.

- Mapeamento dos eventos do eSocial

 

This element is not expected

1. Verifique na mensagem do erro apresentada qual a tag não era esperada e qual era a esperada pelo governo. No exemplo abaixo, o erro indica que a tag ageIntegracao não era esperada na ordem do XML, pois a tag esperada era a instEnsino;

mceclip10.png

2. Abra os XML do RM e TAF e pesquise pela tag indicada no erro. No exemplo abaixo, de acordo com o erro apresentado no passo 1, a tag pesquisada foi ageIntegração;

mceclip8.png

3. Conforme leiaute, o grupo instEnsino é obrigatório e, por isso, era esperado antes do grupo ageIntegracao;

mceclip9.png

4. Sendo assim, verifique no Mapeamento do eSocial a origem da tag. Sendo uma informação preenchida pelo usuário, corrija o campo preenchido no sistema. Sendo uma informação gerada internamente pelo sistema, acione o atendimento técnico com as evidências para análise.

- Mapeamento dos eventos do eSocial


Saiba mais
Acesse o link abaixo para baixar os layouts do eSocial:
      • Documentação Técnica

Esse artigo foi útil?
Usuários que acharam isso útil: 0 de 1

0 Comentários

Por favor, entre para comentar.
X Fechar

Olá ,

Há pendência referente a um de seus produtos contratados para a empresa ().

Entre em contato com o Centro de Serviços TOTVS para tratativa.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cobrança – Verificação de pendências financeiras . clique aqui.

TOTVS

X Fechar

Olá ,

Seu contato não está cadastrado no Portal do Cliente como um perfil autorizado a solicitar consultoria telefônica.

Por gentileza, acione o administrador do Portal de sua empresa para: (1)configurar o seu acesso ou (2)buscar um perfil autorizado para registro desse atendimento.

Em caso de dúvidas sobre a identificação do contato administrador do Portal, ligue (11) 4003-0015, opção 7 e, em seguida, opção 4 para buscar o suporte com o time de Assessoria ao Portal do Cliente. . clique aqui.

TOTVS

X Fechar

Olá ,

Para o atendimento de "Consultoria Telefônica" você deverá estar de acordo com o Faturamento.

TOTVS

X Fechar

Olá,

Algo inesperado ocorreu, e o usuario nao foi reconhecido ou você nao se encontra logado

Por favor realize um novo login

Em caso de dúvidas, entre em contato com o administrador do Portal de Clientes de sua empresa para verificação do seu usuário, ou Centro de Serviços TOTVS.

Ligue! 4003-0015 opção 4 e 9 ou registre uma solicitação para CST – Cadastros . clique aqui.

TOTVS

Chat _

Preencha os campos abaixo para iniciar o atendimento:

Chat _