Ocorrência
Ao alterar um registro gera o Help: Mensagem: O registro número X do Arquivo X encontra-se Bloqueado por outro usuário.
Ambiente
Cross Segmentos-TOTVS Backoffice (Linha Protheus)-Faturamento (SIGAFAT) - a partir da release 11.80.
Causa
Esta inconsistência pode acontecer nas situações abaixo:
1º Registro Bloqueado por outros Usuários (possivelmente com instância presa);
2º Parâmetros que auxiliam na resolução da reserva de registros;
3º Customizações / Personalizações em seu ambiente.
Solução
Para solucionar, acesse a F.A.Q. para entendimento do processo e efetue as avaliações propostas:
1- Em caso de registro bloqueado por outro usuário, uma opção paliativa rápida é reiniciar o servidor (parando os serviços do TOP, Banco de dados e Server);
2- Desabilite os parâmetros MV_GNRENF e deixe MV_FATTRAV = 4
3-Em caso de customizações ou personalizações no ambiente, tente efetuar um teste com um RPO padrão baixado do portal e com os pontos de entradas desabilitados no catálogo de personalizações do Configurador
Para mais detalhes, acesse: O registro encontra-se bloqueado por outro usuário
0 Comentários